Problem with B & W 801 series II Speaker

Discussion in 'Audio Hardware' started by charles robertson, Apr 20, 2017 at 7:10 PM.

  1. charles robertson

    charles robertson Well-Known Member Thread Starter

    Location:
    Ohio
    I picked these up a few months ago and just got around to hooking them up. All is good with the exception of one of the woofers not working. Any ideas or suggestions?
    I did pop the speaker out and made sure the connections were ok.........stumped.
     
  2. timind

    timind Forum Resident

    Location:
    Brownsburg, IN USA
    Did you check for continuity from the crosssover to the speaker driver? Did you check continuity of the speaker itself while you had it out?
     
  3. charles robertson

    charles robertson Well-Known Member Thread Starter

    Location:
    Ohio
    How do I do that? Im not super hands on when it comes to this kind of stuff.
     
  4. timind

    timind Forum Resident

    Location:
    Brownsburg, IN USA
    It sounds as if you don't have an ohm meter which is what you use to check continuity.
     
  5. charles robertson

    charles robertson Well-Known Member Thread Starter

    Location:
    Ohio
    Correct I dont have one.
    Im sure I can pick one up.
     
  6. RiCat

    RiCat Well-Known Member

    Location:
    CT, USA
    You might give B&W a call and check to see if there are fuses on the crossovers. If a fuse is blown it may indicate a speaker issue or that the previous owner pushed them to hard with an amp that started to clip. I do not remember if those speakers had internal fused crossovers. Maybe another owner could say exactly.
     
  7. charles robertson

    charles robertson Well-Known Member Thread Starter

    Location:
    Ohio
    ok Ill ring them in the am.....thanks
     
  8. timind

    timind Forum Resident

    Location:
    Brownsburg, IN USA
    A google search showed me this crossover pic, I don't see any fuses but they could be in line instead of mounted on the board. If you pulled the driver out, it should be easy enough to remove the crossover, Probably easier than the driver.
    [​IMG]
     
  9. Hendertuckie

    Hendertuckie Active Member

    Location:
    Henderson, Nevada
    I have 801 Series 3 and mine have an access door to the crossover located on the bottom side of the cabinet. Also taking the bass driver out is fairly easy and will make visual inspection a breeze. I had an issue with the cable connection lugs. They had become loose and caused the tweeter and mid drivers to stop working. I unscrewed the plastic lug holder and re-secured the wires.

    Good Luck
     
    timind likes this.
  10. charles robertson

    charles robertson Well-Known Member Thread Starter

    Location:
    Ohio
    timind Where exactly is the crossover located?
     
  11. charles robertson

    charles robertson Well-Known Member Thread Starter

    Location:
    Ohio
    ok I now have both woofers working. I had the speaker wire on the wrong terminals on the back of the speakers. Only problem now is that they are base heavy.....tweeters almost non existent?
    Do the tweeters need to be hooked up with the other two terminals?
     
    Mad shadows likes this.
  12. beppe

    beppe Member

    Location:
    Venice, Italy
    Woofer, midrange and tweeter must be connected to the amplifier. If you have two binding posts on the back side of any loudspeaker you have to connect all the red and, separately, connect all the black. Then you can connect wires (+ and -) respectively to the red and black cable.
     
  13. SHU

    SHU Member

    Location:
    Netherlands
    Hi Charles, it sounds like you're missing the jumpers. connect both black terminals and connect both red terminals using some speaker wire. That should fix it

    edit: Beppe beat me to it
     
    Dave likes this.
  14. charles robertson

    charles robertson Well-Known Member Thread Starter

    Location:
    Ohio
    Ok Ill give it a try.....Thanks guys!
     
  15. charles robertson

    charles robertson Well-Known Member Thread Starter

    Location:
    Ohio
    Hey that worked
    I'm good to go now
    Thanks guys for all of your help
    Really appreciate it
     
    timind, Mad shadows and Ham Sandwich like this.

Share This Page