"Audio device buffer underflowed..." Help rid me of this buffer error

Discussion in 'Audio Hardware' started by Cindy Burns, Jul 1, 2014.

Thread Status:
Not open for further replies.
  1. Cindy Burns

    Cindy Burns New Member Thread Starter

    I have been using Pro Tools LE MBox Pro 2, version 7.1.3, with my iMac for the last 14 months, without any real problems.

    Suddenly, a few weeks ago, I start getting an error message when I playback or record (mostly recording): "Audio device buffer underflowed. If this occurs frequently, try decreasing the H/W Buffer Size in the Playback Engine or remove other Firewire devices (-6085 or -6086)" . The message sometimes comes within a few seconds of starting a session, or can come up to an hour or so into a session. But each time it occurs the session will then no longer allow me to continue either recording or playing back for very long.

    My specs:
    iMac Intel 2.16 GHz
    OS x 10.4.11 (I had 10.4.9 when this error message started a few weeks ago)
    Space: 447.33 GB available

    I save my Pro Tools sessions to the internal drive. All my sessions are currently being saved in my documents file, although to be honest I tend to delete them after a short time, when I have had the chance to put the final mix onto a CD or Dat tape.

    As for external hardware - other than the MBox going into the FW400 port on the back of my Imac, just a printer via USB and my BT router via its thing. No other FW port is in use.

    Things I have tried:

    *As it suggests in the message, I have tried decreasing the buffer, plus increasing it, to no avail.
    *I bought a new Firewire cable (because a Digidesign engineer told me that "The DAE errors 6086,-6085,-6097 all relate to communication error as a result of a interruption or conflict with the data throughput to the unit."). No joy.
    *I talked to an engineer about geting an external drive, but they don't think this could help.
    *I reinstalled Pro Tools LE.
    *I tried the two following workarounds I found on a website (they are meant to work with version 7.3.1, but worth a try with 7.1.3 I reckoned): "Connecting Mbox 2 Pro after the Mac has booted will prevent this behaviour." and "Quit Pro Tools, disconnect then reconnect the Firewire cable, then re-launch Pro Tools". Neither worked, as sooner or later the pesky buffer message comes up.
    *Resetting the PRAM hasn't worked
    *Repairng permissioms hasn't worked
    *I followed the recommended tips to ensure that my iMAC is fully optimised to run, tweaking settings, deleting the preferences etc.

    The engineers tell me that 10.4.11 is not supported with my version of Pro Tools, which I accept. However, this error message was coming up when I had OS X 10.4.9, only a few weeks ago, and is still doing it now that I have 10.4.11 (no change), so I can't see how having 10.4.11 is causing this buffer error.

    Quite a wretched problem this is turning out to be, having explored so many trouble shooting ideas already I hope someone here might have a fresh idea that might do the trick!

    Thanks in advance,
    Kodok Ngorek


    [​IMG]
     
  2. gloomrider

    gloomrider Well-Known Member

    Location:
    Hollywood, CA, USA
    Have you considered updating the OS to at least 10.6 (Snow Leopard)? OS 10.4 (Tiger I think) is like 10 years old.
     
  3. gingerly

    gingerly Forum Resident

    I've had this kind of thing happen when my HD is too full or fragmented. I would try freeing up space so that at LEAST 20% of your HD is free and empty. File fragmentation can also cause this problem, but having a decent amount of free space should make that less of an issue.

    *edit* I see you have 447GB available. You could also use an app like Onyx or System Optimizer to force cache cleaning and the running of Unix maintenance scripts. These things often contribute to flaky behavior in older versions of OSX.
     
  4. Jim T

    Jim T Forum Resident

    Location:
    Mars
    Is this possibly a driver issue? I used to do firewire recording years ago on a PC and my driver became an issue. I think I used ASIO4all to solve that problem. Not sure about a Mac, sorry.

    These are the issues that drove me out of fire wire computer recording and into SDHC card outboard units. Now my computer is for mastering and disc burning only.
     
  5. ElizabethH

    ElizabethH Forum Resident

    Location:
    SE Wisconsin,USA
    Aside from hard drive needing defragmentation, it may be some new (hidden to you) program is now running all the time and interrupting the flow TO the buffer enough, so it is failing.
    A LOT of audio problems in computers relate to interrupted data flow caused by background programs running too often and having a 'higher' priority than the audio data.
    usually one can set the priority of programs in some menu so the background programs are always a low or medium, and the audio is high.
    I would bet you have some new (unknown to you) program running all the time now. And it has top priority over your other programs.
    I am no computer wiz, so how to access these and adjust the priority levels on a Apple is ??? to me.

    I hate the fact computers never give a straightforward display of EVERY program running and a real name for it you can trace. it is always hidden with never a name given you can follow, and obfuscated stuff you have NO idea what it is there for... (Rant over).
     
  6. gingerly

    gingerly Forum Resident

    Actually, this is a good idea. Run the app Activity Monitor, and it will show you what processes might be hogging your CPU. Anti-virus apps often do this, or Flash pages, or Java running in your browser.
     
Thread Status:
Not open for further replies.

Share This Page