Dismiss Notice
We are rebuilding the search index and other forum caches this morning. Search results may not appear correct until indexing has completed, and the forum may respond a little slower than normal until this has finished.

Cocktail Audio X14 in endless reboot loop/hell

Discussion in 'Audio Hardware' started by Vick Griffin, Nov 22, 2020.

  1. Vick Griffin

    Vick Griffin Active Member Thread Starter

    This is probably a long shot, but I purchased a Cocktail Audio X14 from April of '19. Great piece of gear to add to my audio setup; granted, it didn't get much use for the last 10 months as I wasn't working and sheltering at home during these crazy times and my audio setup was in my work apartment two states away. Have used it sparingly since returning this month and a problem has reared its ugly head. Upon turning on the X14, it simply cuts off and reboots over and over in an endless loop. I opened it up and removed the hard drive I installed inside, thinking maybe the drive was the culprit but no such luck. Any suggestions or ideas - can't find a product-specific message board anywhere that might have some other enthusiasts and their tech support leaves something to be desired. Thanks!
     
  2. bever70

    bever70 It's all about the soundstage

    Location:
    Belgium
    Have you sent an email to cocktailaudio/novafidelity ? I always got pretty quick answers when I had questions regarding my x40.
     
  3. Vick Griffin

    Vick Griffin Active Member Thread Starter

    Yep - sent one to nova and to the distributor from where it was purchased. They say "lifetime tech support" on their website so we shall see...
     
  4. Vignus

    Vignus Digital Vinylist

    Location:
    Italy
    I bought one a couple of years ago. I was fine for a week then, after a software update, it did the same you are describing. It couldn't re-index all the music and went into an endless loop. After a couple of mails with their support (they couldn't solve the issue) I sent it back and bought a Cambridge network player.
    Did you try to set it back to factory settings and run the update again?
     
  5. Vick Griffin

    Vick Griffin Active Member Thread Starter

    Not sure how to set it back to factory settings when it won't stay on unless there's something I don't know about...
     
  6. bever70

    bever70 It's all about the soundstage

    Location:
    Belgium
  7. Vignus

    Vignus Digital Vinylist

    Location:
    Italy
    I don't remember how to do that but, if you search in the manual, there should be a key combination for that?
     
  8. Vignus

    Vignus Digital Vinylist

    Location:
    Italy
    I just looked online and couldn't find any way to reset it using a key combination, sorry. The above mentioned X12 forum covers also X14. Try posting there?
     
  9. Vick Griffin

    Vick Griffin Active Member Thread Starter

    Thanks for the forum links that's just what i was looking for!
     
  10. bever70

    bever70 It's all about the soundstage

    Location:
    Belgium
    Don't get your hopes up too high, sadly not a lot of activity going on there.
     
    Vick Griffin likes this.

Share This Page