KEF LS50 Wireless users, need help.

Discussion in 'Audio Hardware' started by Gokce, May 20, 2019.

  1. Gokce

    Gokce Active Member Thread Starter

    Location:
    Istanbul
    Hi,

    I bought them yesterday evening and setup was a breeze.. Did the updates without any issues.

    Two things I noticed though;

    First is when I try to power off from KEF Connect app, speakers power down but afterwards the application give error that the speakers can not be found. I guess the reason is it loses the wifi connection but therefore, it becomes impossible to power on from the app. I need to use the remote to power on. Which makes using app to power off and on pointless. Any users have same issue ?

    Second is when I power off, speakers make a very short and low static kind of sound. Only heard when next to it and only when power off. It is not the amp clicking sound when its power on and power off. Its like turntable needle makes when it sits on LP. very low, one or two static noise.

    Many thanks in advance for all the inputs.
     
  2. NYMets41

    NYMets41 Forum Resident

    Location:
    USA

    Nothing you can do about the app, but do contact your dealer or KEF customer service about static.

    It may be the overheat shield that they’ll replace with the updated one.
     
  3. Gokce

    Gokce Active Member Thread Starter

    Location:
    Istanbul
    Hi,

    Thank you very much for your answer. So you mean it should not be common behavior of the LS50W when powering up or turning off ? You have the same speakers and don't experience the same ?

    Those are very few and very very quiet ticks in this order and seems to be from left speaker ;
    1. power off button
    2. “ very quite ticking” sound
    3. relay click in left speaker
     
    NYMets41 likes this.
  4. freesole

    freesole Forum Resident

    Location:
    Seattle, WA
    When I power my LS50W off, I don't hear any sort of static but hear a double click sound after the short tune indicating that I am turning off the speakers.
     
    NYMets41 likes this.
  5. NYMets41

    NYMets41 Forum Resident

    Location:
    USA
    KEF said they replaced a heat shield that produced static. The newer models use the updated heat shield.

    Excellent customer service.
     
  6. Gokce

    Gokce Active Member Thread Starter

    Location:
    Istanbul
    From which month/year produced models have this updated heat shields ?
     
  7. NYMets41

    NYMets41 Forum Resident

    Location:
    USA

    I don’t know but will email.
     

Share This Page