Dismiss Notice
We are making some updates and reconfigurations to our server. Apologies for any downtime or slow forum loading now or within the next week or so. Thanks!

OPPO players HDCD issue

Discussion in 'Audio Hardware' started by strettonufo, Dec 14, 2020.

  1. strettonufo

    strettonufo Member Thread Starter

    Location:
    sooke bc
    My OPPO BDP95 player sends audio over HDMI to NAD receiver. Worked great for SACD, DVDA, HDCD and CD. HDMI is the only output from the OPPO. Yesterday played a Tom Petty HDCD and the audio stuttered. Substituted my backup OPPO BDP103. Same issue!! Played Roxy Music Avalon. Same problem. Thinking licensing issues? Have quite a number of favorite titles on HDCD: Roxy Music, Cars, Doors, King Crimson, Kinks .. and like the sound HDCD brings.
     
  2. Bill Mac

    Bill Mac Forum Resident

    Location:
    So. ME USA
    Did you try disabling HDCD decoding in the Audio Format Setup in the menu? Then you would know if it's specifically an HDCD issue.

    Page 64 - http://download.oppodigital.com/BDP95/BDP-95_English_Manual_v1.5.1.pdf
     
    Sevoflurane and BGLeduc like this.
  3. Edit: Bill beat me.

    My 93 had issues when connected to a AVR that could decode HDCD. But the fix was simple. The Oppo has a HDCD setting in the menus. I just had to turn it off when doing the decoding externally. I assume the 95 is the same. Easy enough to give it a shot.
     
    audiomixer, Sevoflurane and Bill Mac like this.
  4. strettonufo

    strettonufo Member Thread Starter

    Location:
    sooke bc
    Thanks. Yes, I did turn off HDCD in the Oppo players settings. The disc played back but I don't think my NAD receiver decodes HDCD. I have been running the same setup for years and never had to be concerned about the receiver because the player decoded HDCD. Curious that both my '95 and '103 stopped decoding HDCD. The last time I remember playing back an HDCD was a couple of months ago: Avalon sounded great.
     
    c-eling likes this.
  5. Bill Mac

    Bill Mac Forum Resident

    Location:
    So. ME USA
    Did you try a different HDMI cable? It's a shot in the dark but worth a try. I can't see how it could be an HDCD licensing issue. If your 95 and 103 played HDCDs before how could that feature be removed?
     
    Uglyversal and c-eling like this.
  6. c-eling

    c-eling New horizons come and go...

    I'd go with analog out and let the Oppo do the decoding. -give that a try.
    Avalon I believe doesn't have peak extend, same 'mastering' decoded or not.
     
    fluffskul likes this.
  7. strettonufo

    strettonufo Member Thread Starter

    Location:
    sooke bc
    if the licensing was programmed into the players with an expiry date, which has now passed. |Shot in the dark, I know.
     
  8. strettonufo

    strettonufo Member Thread Starter

    Location:
    sooke bc
    Also, plays back fine if I turn off HDCD in the player options. I believe this eliminates the HDMI cable as the problem.
     
  9. Bill Mac

    Bill Mac Forum Resident

    Location:
    So. ME USA
    Highly doubtful. There are quite a few 103/5 series players out there and if HDCD was disabled many owners would be up in arms.
    Turning off HDCD does not indicate that it's not the HDMI cable. That's because the Oppo isn't decoding HDCD with it turned off. I think it's a long shot but if you have an extra HDMI cable it's worth trying.
     
    vegafleet likes this.
  10. strettonufo

    strettonufo Member Thread Starter

    Location:
    sooke bc
    taken time off for family stay at home vacation. Did everything suggested including changing the hdmi cable. Plays back fine if hdcd is turned off. Stutters if turned on. True for both my 95 and 103 oppo players, with multiple hdcd discs. Thanks for all the help. If I do crack this I will let you know.
     
    MayoStudenT likes this.
  11. TarnishedEars

    TarnishedEars Forum Resident

    Location:
    Seattle, WA
    No, my 103 is still decoding HDCDs as well as ever. However: I haven't upgraded the firmware on my 103 in over 5 years. So perhaps later firmwares might have issues with HDCD? Afterall, Oppo did drop HDCD in the 203 and 205.
     
  12. Tullman

    Tullman Senior Member

    Location:
    Boston MA
    Now I have to try an HDCD in my 105, today.
     
  13. Tartifless

    Tartifless Forum Resident

    Location:
    France
    Do you have a TV connected to the oppo ? Is it a sony ?
     
    fluffskul likes this.
  14. NAD at one time did decode HDCD. I had a 762 which required that I disable HDCD in my 93.

    Knowing the AVR you have will be helpful.
     
  15. Tullman

    Tullman Senior Member

    Location:
    Boston MA
    Listened to an HDCD today and the it played beautifully on my Oppo 105.
     
    audiomixer and TarnishedEars like this.
  16. Sevoflurane

    Sevoflurane Forum Resident

    My BD103 still decodes HDCD. @Bill Mac has answered this one with the appropriate quote from the manual. Case closed.
     
    audiomixer and Bill Mac like this.
  17. fluffskul

    fluffskul Would rather be at a concert

    Location:
    albany, ny
    my oppo was having a similar issue , and I emailed them and they told me to make sure TV was always on when playing back.

    I do that now and no more stuttering. Just curious why you mentioned Sony specifically .
    My TV is Sony. Is this stuttering problem unique to oppo/Sony combos?
     
  18. Sterling1

    Sterling1 Forum Resident

    Location:
    Louisville, KY
    Maybe removed with an auto firmware update?
     
  19. Sevoflurane

    Sevoflurane Forum Resident

    Doubt it. IIRC, the HDCD decoding is a function of the chipset. Oppo are no longer developing or marketing their players. HDCD has been largely abandoned by Microsoft since they took it over. There’s zero motivation for anyone to write new firmware that disables it.

    Besides, as stated above, the manuals advise disabling HDCD decoding in certain circumstances to prevent exactly the issue described by the OP. This is a known issue.
     
    Bill Mac, audiomixer and Sterling1 like this.
  20. Victor Martell

    Victor Martell Forum Resident

    Not really the question, of course, but answering in case it helps - no issues here Oppo BDP 103 HDCD --> Schiit Bitfrost 2 via Optical - obviously the Bitfrost does not decode HDCD... so maybe on to something on the possibility of double decoding being the issue... One software update when I got it a couple years ago (By mistake! :D ) but nothing since then... will update with version if I have the chance.

    v
     
  21. Bill Mac

    Bill Mac Forum Resident

    Location:
    So. ME USA
  22. Rose River Bear

    Rose River Bear Forum Resident

    My 103 is still working fine and decoding HDCD.
    I have never done a firmware update. I guess I should. What do you think Bill?
     
    Bill Mac likes this.
  23. Bill Mac

    Bill Mac Forum Resident

    Location:
    So. ME USA
    That's a tough one RRB. If your 103 is working well then I'd be inclined to not update the firmware. I've always had faith in Oppo support and normally updated the firmware when a new one was available. Especially if the update corrected a known issue or added capability/features.

    What you could do is check out the link below from the Oppo site. It lists the history of all the 103/105 firmware updates and the items that were corrected and features that were added. It looks to be a long bit of reading but might offer you some insight on whether to update or not.

    103/105 firmware update history - OPPO Digital - Ultra HD Blu-ray Disc Players
     
    superstar19 and Rose River Bear like this.
  24. audiomixer

    audiomixer As Bald As The Beatles

    Firmware updates ended a long, long time ago for these players.
     
    Rose River Bear likes this.
  25. Bill Mac

    Bill Mac Forum Resident

    Location:
    So. ME USA
    True, but RRB never did a firmware update at all on his 103. So there are firmware updates available for his 103 as it has the original firmware.
     

Share This Page

molar-endocrine