SACD ripping, Mac/Oppo. How, exactly?

Discussion in 'Audio Hardware' started by gd0, May 15, 2017.

  1. gd0

    gd0 Looney Tunes and Merrie Melodies Thread Starter

    Golden Gate
    Apparently, the SACD Ripping Service thread is not the place for this, so here's a fresh one. Here is an account of my failed attempt there: Anyone tried this SACD Ripping service?

    Like others, I've poured over the oft-linked thread at Computer Audiophile. This is what I believe to be the most recent "simplest Mac" post: SACD Ripping using an Oppo or Pioneer? Yes, it's true!

    Therein it's evident that Java is required in some fashion. My unique(?) situation is that I uninstalled Java some years ago, and I will not re-install. That said, I found this Roon thread that discusses a workaround; see the post by "muski": SACD ripping with Oppo or Pioneer

    It has been suggested that the CA instructions include unnecessary steps, FWIW.

    I believe the process, in the plainest terms, is like this:

    1. Download 3 items from links in CA.
    2. Two of them are Autoscripts which are dragged to a USB stick.
    3. The 3rd one is a "sacd_extract" file, which is placed... somewhere on the Mac(?)
    4. Identify and/or enable the sacd_extract file by some method of programming(?)
    5. Boot Oppo, adjust settings, connect to network.
    6. Insert USB stick, load SACD disc.
    7. Somehow(?) access the sacd_extract file and enable it to rip.

    If I've got that right, everything is clear except 3, 4, and 7. There is some sort of programming detail which is glossed over in every instruction. EXACTLY how do you manage that sacd_extract? Even if this entails basic programming which most users (esp on CA) take for granted, it's unclear to me. In 3 decades I've never programmed anything, no Applescripts, no nothing. No need.

    I may be complicating things by refusing to install Java, but that won't change. Which apparently steers me to creating Terminal commands, another unfamiliar arena for me. If I'm to do these, I need to know EXACT text to input, and EXACT ways to input them. It's my general understanding that imprecise Terminal commands can cause damage.

    2013 iMac MacOS Sierra, Airport Extreme hardwired, Oppo 103.

    Any input or links appreciated.
    gammarayson likes this.
  2. Rolltide

    Rolltide Forum Resident

    Vallejo, CA
    sacd_extract is a java app, no java no work.

    I think even the command line version can't get around this.
    hvbias, BayouTiger and McLover like this.
  3. deadcoldfish

    deadcoldfish Forum Resident

    Santa Rosa, CA
    go back and read the post by "muski":

    I recommend copying the sacd_extract binary file to the directory where you want to store your SACD files. Then open a Terminal window, cd to that directory (eg. cd ~/Music/SACD) and use:

    ./sacd_extract -2 -s -c -i

    Where is the local IP address of the Oppo (besides the Oppo remote app, you can also see the IP address by turning on your TV and going to the Settings->Network screen on the Oppo).

    Note that the -2 option rips the stereo layer only.

    No Java needed for the Command Line invocation using Terminal.
    TonyCzar, JediJoker, bru87tr and 2 others like this.
  4. deadcoldfish

    deadcoldfish Forum Resident

    Santa Rosa, CA
    and you're not "creating" Terminal commands, you're executing a program/script from Terminal, with options passed to it on the command line.
  5. tmtomh

    tmtomh Forum Resident

    I'm the one who wrote the "simpler" Mac instructions. They've become referred to (not by me) as the "simple" instructions because the ISO2DSD Java app uses a graphical user interface, which is easier to operate than the command-line interface of sacd_extract.

    However, if you won't install Java, then you have to use the sacd_extract command-line (Terminal) app, and @deadcoldfish has given very good instructions on that.

    In those instructions, what you're doing is launching the Terminal, and then telling the Terminal to look where the sacd_extract app is - that's the "cd ~/Music/SACD" command. The key here is that you can put sacd-extract wherever you want, but wherever that is, that's where your SACD rips will be too. You can of course move each SACD rip wherever you want once it's been completed. The "~" character (upper-left on a Mac keyboard, just to the left of the 1 key and just below the ESC key) is a shortcut for "my home directory." So for example ~/Music is the Music folder in your home directory.

    Also, you don't want to put sacd_extract or your SACD rips in ~/library/caches or any library folder - everything in the Library folder is meant to be created and managed by the Operating System and your various apps. Just put sacd_extract in your Music folder, or your Home folder, or your Applications folder, or a new folder you make just for that purpose.

    Once you run that "cd" command, Terminal will know where to find sacd_extract. Then when you type the next command - the one starting with ".sacd_extract..." - the -2 -s -c -i bits are called "flags." Flags basically say, "Hey, sacd_extract, please run now, but do so with these parameters." I forget what each one stands for, but just use them - they're the right ones.

    After that is the IP address of your Oppo machine on your network. You say you already know that, which is great. One thing to keep in mind: no leading zeros in the IP address. So this would be wrong: - and this would be right: (These are just examples; your numbers will be different.). And don't forget the :2002 at the end.

    Type in that command, press return, and 15-20 minutes later you should have a large ISO file in the same folder that sacd_extract is located.
    Kyhl, jfeldt, Bingo Bongo and 5 others like this.
  6. gd0

    gd0 Looney Tunes and Merrie Melodies Thread Starter

    Golden Gate
    Thanks @tmtomh

    The Terminal explanation is very helpful; I've only used it a couple times under strict supervision.

    A couple lingering questions:

    Is it routine for the Oppo IP address to change from one day to the next? It has done so here.

    If, upon inserting the USB stick, the Oppo tray doesn't open on its own as described, does that mean something is still wrong? The Oppo indicates a USB is added. I've tried 2 different USB sticks; using Get Info, the format is described as: MS-DOS (FAT32). I have a couple others, and I guess I can re-format if needed.

    Is it correct to find two Autoscripts in the original download, in addition to the sacd_extract? The ones I found are named: AutoScript.txt and AutoScript.TSS.txt

    Thx again.
    head_unit and tmtomh like this.
  7. Black Elk

    Black Elk Music Lover

    Bay Area, U.S.A.
    The arguments for the sacd_extract command are:

    -2 = export 2-channel tracks (default)
    -m = export multi-channel tracks
    -e = output in Philips DSDIFF (Edit Master) file format
    -p = output in Philips DSDIFF file format
    -s = output in Sony DSF file format
    -t = output only selected tracks
    -I = output ISO file
    -c = convert DST to DSD
    -C = export a CUE sheet
    -i = set input source
    -P = Print, i.e., display disc and track information during extraction

    I leave the USB stick in the Oppo.

    If the Oppo is picking up an IP address using DHCP, then, yes, it can change. You can get around this by using IP address reservation in your router (or setting a static ip address).
    hvbias, liv3evil, jfeldt and 3 others like this.
  8. tmtomh

    tmtomh Forum Resident

    Glad it was helpful! RE your questions:

    Oppo IP address:
    Most of us have home networks where the router assigns each network device (computer, Oppo, smartphone, Roku box, whatever) a dynamic IP address. That means the IP address can indeed change. So it usually will not change on a daily basis, but it will eventually change.

    I don't know all the ins and outs, but from my experience, some routers seem to "remember" devices better than others. So if you have a power outage, your router might assign all your devices new IP addresses, in the order it detects them coming back up on your network. Or your router might remember the devices and assign them their previous IP addresses. Likewise, if you have a lot of smartphones, laptops, iPads etc in the house - devices that drop off your network a lot because they travel with people outside the house - then you can get more IP address churn as your router assigns those devices new IP addresses when they show up on the network again. And if your Oppo is turned off while a few traveling devices come back home, your router could end up assigning one of those devices the IP address that the Oppo used to have. Again, some routers are smarter about this, can remember traveling devices better, and won't assign previously used IP addresses to new devices.

    As @Black Elk notes, you can assign one or more devices (like the Oppo) a static IP address on your network if this really bothers you. How to do that depends on your router model.

    I believe one of the Oppo's on-screen menus (Settings?) will show you the current IP address, as will the Oppo MediaControl smartphone remote app. And the free LanScan app will show you too: LanScan on the Mac App Store

    USB Stick:
    If the Oppo's tray doesn't automatically open, there's probably something wrong. The most common issues people have with the USB stick are:
    • The Autoscript folder is not at the root/base level of the USB key (or only the files inside the Autoscript folder have been copied to the USB key, instead of the Autoscript folder and its contents); OR...
    • The USB key has been formatted in a way the Oppo doesn't like: On a Mac, you need to take care in Disk Utility to format the USB not only with the DOS/Windows filesystem, but also as MBR/Master Boot Record; OR...
    • Some people report that trying a different USB key, notably a smaller-capacity one, helps.

    Autoscript Folder:
    Mine has three items: Autoscript, Autoscript.TSS, and sacd_extract. None of the files has a ".txt" extension at the end of the name.
  9. deadcoldfish

    deadcoldfish Forum Resident

    Santa Rosa, CA
    you'll need to remove the ".txt" suffix from the Autoscripts.
    hvbias and tmtomh like this.
  10. gd0

    gd0 Looney Tunes and Merrie Melodies Thread Starter

    Golden Gate
    Thanks guys.

    Fluctuating IP addresses are not a problem as long as I know it's not creating a logjam.

    2-ch and 5.1 rips must be done separately, yes?

    My intent is to try and see if JRiver can play back ISOs directly. If not, I'm comfortable converting audio file types. And I'm certainly not married to DSD/DSF. Is any of these best for retaining tags?

    There are no folders, just individual files (see jpeg). Can I simply create a folder? Does it have to be named something special?

    #1 is what I see first at the download link:


    Click Autoscript folder, I get #2. Click sacd_extract folder, I get #3. So I downloaded individual files. And now I'm not even sure which sacd_extract materials I'm supposed to have. Too many unexplained choices. Download all, and hope nothing bad happens?

    I tried to do an erase on one USB key in Disk Utility, and there is no MBR option. Of course.

    FWIW, I've used both of these drives to successfully play music files on the Oppo.

    Already tried two, one is 4GB. Think I've got one more around here somewhere.

    Just a simple delete?

    Entering Day Three of trying to just get by Page 1.

    "It's Easy"
    hvbias likes this.
  11. tmtomh

    tmtomh Forum Resident

    Your AutoScript folder looks fine - when you double-click it, you get the proper three files inside, with no ".txt" suffix on them, so that looks good. So copy that AutoScript folder (including the three files inside it) into a Windows-formatted USB key.

    The 2nd folder - "sacd_extract" - you can ignore. The two files in there - sacd_extract.exe and sacd.cmd - are for Windows computers, not for the USB keym and not for your Mac.

    As for formatting the USB key in Disk Utility, you have the MBR option. I can't remember exactly how to access it, but I believe in the "Erase" tab, when you are selecting Windows/DOS format, there is an Options button or some such. If you click that before erasing/formatting, it should pop up a window or panel with three options: GUID partition map, Apple partition map, and Master Boot Record. Choose Master Boot Record, then click Okay, and it should return you to the prior window where you can then execute the erasure/formatting.
    hvbias likes this.
  12. Black Elk

    Black Elk Music Lover

    Bay Area, U.S.A.
    I'm a Windows user, so can't help you on the Mac specifics, but, no, you do not need to rip the 2-ch and M-ch separately. You can rip to ISO, which contains both. You can then opt to play from the ISO, or use something like Sonore's ISO2DSD to split the ISO into stereo and/or M-ch DSF files (which are better for tagging).

    Sonore - ISO2DSD - converts ISO files to DSD
    hvbias and gd0 like this.
  13. gd0

    gd0 Looney Tunes and Merrie Melodies Thread Starter

    Golden Gate
    Maybe I wasn't clear.

    Those folders in the jpeg reside only at the link from CA. I could not download them as is; If I click the Autoscript folder it takes me to another webpage where the 3 individual files can be downloaded individually.

    This very initial step could be part of my problem.

    Again, once individual files are downloaded, can I simply create a new folder with some appropriate name ("Autoscript" ?) that will be recognizable?

    Thanx again, guys.
  14. tmtomh

    tmtomh Forum Resident

    Ah, I see. When I open the web page, I don't click on the AutoScript folder in the Dropbox web page - I cluck on the "download" link near the top-right of the web page - specifically the "download directly" option (not the "save to my Dropbox" option). After a few seconds, a ZIP archive downloads to my Mac's downloads folder. I then double-click on that ZIP archive and the Mac unZIPs it, giving me a folder called SACD, and inside that are the AutoScript and sacd_extract folders.
    gd0 likes this.
  15. gd0

    gd0 Looney Tunes and Merrie Melodies Thread Starter

    Golden Gate

    27" display + tiny text + thin font + grey on white + old eyes = invisible.

    tmtomh likes this.
  16. Kal Rubinson

    Kal Rubinson Forum Resident

    No. One rip to ISO contains both stereo and multichannel tracks.

    JRiver can play the stereo and multichannel tracks directly from an ISO.

    Definitely. DSF is best.[/QUOTE][/QUOTE]
    JediJoker, RolandG and gd0 like this.
  17. mfidelity

    mfidelity Forum Resident

    San Francisco
    Also, if you have another drive plugged into one of the other USB ports the tray may not open.
    hvbias, tmtomh and gd0 like this.
  18. gd0

    gd0 Looney Tunes and Merrie Melodies Thread Starter

    Golden Gate
    Thanks Kal!

    So the sample command (in bold) must be modified per @Black Elk 's list depending on what is wanted?

    If I want an ISO of both 2-ch and 5.1, do I ditch the -2 and replace with -I? Retain -c? Ditch -c?

    Any other custom commands?
  19. gd0

    gd0 Looney Tunes and Merrie Melodies Thread Starter

    Golden Gate

    I downloaded the correct folders, put sacd_extract in a better place (Users/me/Music/SACDrips), and made my way to that folder with Terminal. Oppo reacted correctly per instructions.

    Copied and pasted the suggested command to start the rip, but I get only "Permission denied" responses. I tried mild variations in addition to the original (2-ch) sample:
    I guess I'm close, but am probably entering something wrong.

    Stuck again.
  20. Black Elk

    Black Elk Music Lover

    Bay Area, U.S.A.
    Yes, you change the arguments in the command, depending on what you want.

    Did you make changes in your router to reserve the same IP address for your Oppo? Or assign it a static IP address? That will make things easier. I also use a wired connection to my router, BTW.

    With regard to ripping ISO files, I use the following command (in Windows):

    sacd_extract -i -P -I

    This means the input can be found on port 2002 of IP address, which is the address of my Oppo 105D on my home network. I used DHCP reservation via the MAC address of the Oppo to ensure it always gets the same IP address from the DHCP server.

    The -P means print the progress to the screen, so that you can see some of the data encoded on the disc (title, artist, track titles, ISRC codes, country code, etc., and ripping progress).

    -I means create an ISO image (essentially a snapshot of the structure of the disc). This will create a file of type .iso. The .iso could contain stereo-only, or stereo and M-ch. If stereo-only, the audio could be encoded in raw DSD or DST, if stereo and M-ch it will be encoded in DST.

    I then use Sonore's ISO2DSD (linked above) to extract the stereo or M-ch in DSF format, convert from DST to DSD, and then use mp3tag to tag the files to my liking.

    If your playback software supports ISO files (and tags) to your liking, there is no need to use ISO2DSD.
    hvbias, gd0 and tmtomh like this.
  21. tmtomh

    tmtomh Forum Resident

    I'm just guessing at this point, but if you already have done the "cd" command to point Terminal to the location of sacd_extract, then you might not need the "./" at the beginning of the command that tells sacd_extract to run. So you could try leaving that off.

    Another option is not to do the "cd" command first at all. Instead, just open a Terminal window, then in the Finder navigate to wherever you have put sacd_extract. Then drag sacd_extract onto the Terminal window - Terminal should then auto-fill-in the full and proper file path to sacd_extract. Once it does that, you can use you back and forward arrow keys on your keyboard to add the relevant flags to the command, and to add your Oppo's IP address. Then you can press return and it should work.

    If that doesn't work, then honestly, with respect, you need to get someone to help you in person, who knows their way around Terminal a little.
  22. deadcoldfish

    deadcoldfish Forum Resident

    Santa Rosa, CA
    Permission denied shouldn't be due to the options passed, try this:

    go to that folder containing sacd_extract in Terminal:

    chmod +x sacd_extract

    then try invoking it with the parameters.
  23. gd0

    gd0 Looney Tunes and Merrie Melodies Thread Starter

    Golden Gate
    First, thanks.

    But I'm still stuck. Before I found this morning's posts, I tried to force using sudo (tried a couple ways), no luck. I am the administrator, no one else on this desktop. Shouldn't be a permission issue.

    Note that I'm using the original exact command from linked source, rather than writing my own. I'll customize later when I understand this better. Is there a precise order of commands?

    The exact command entered here has been: ./sacd_extract -2 -s -c -i

    @Black Elk – did not change the router; it's not inconvenient to monitor IP address. System is hardwired.

    @deadcoldfishchmod didn't work, but now instead of "permission denied" all results read "cannot execute binary file." I dunno if that means anything. Also, after chmod, there is now an icon with the sacd_extract file that wasn't there before. Again, dunno if that's meaningful.

    @tmtomh – tried losing the "./" but no difference.
    I dragged sacd_extract to Terminal well enough, but I don't understand using back / forward keys. Does that mean some exact text must be inserted in an exact place? I tried the original command after dragging, but "cannot execute."

    I think I'm close. I'm sure I'm connected correctly. Terminal indicates I'm at the right place. It seems the nature of my command is flawed somehow.

  24. tmtomh

    tmtomh Forum Resident

    Where have you put sacd_extract on your Mac - in other words, in what folder?

    Also, apologies if this is a colossally stupid question, but you have modified the sacd_extract Terminal command to reflect where on your Mac sacd_extract is, yes?
  25. Bill Mac

    Bill Mac Forum Resident

    So. ME USA
    Reading through this thread leads me to believe that ripping SACDs with an Oppo is anything but easy for those without serious computer skills. Much of the discussion is totally over my head as a casual computer user. So those that say "oh, it's easy" are obviously well versed in computers.
    Holy Diver, Pancat and gammarayson like this.

Share This Page