Setup Dragonfly on Ubuntu Linux

Discussion in 'Audio Hardware' started by riff2112, Jan 7, 2014.

Thread Status:
Not open for further replies.
  1. riff2112

    riff2112 Well-Known Member Thread Starter

    Location:
    Arizona
    Hi,
    Just wondering if anyone knows how to setup up Ubuntu to work with a Audioquest Dragonfly. It works great with my Win 7 setup but can't get any sound in Ubuntu Linux 13.10, although it does see the device.( I think!)

    Any help much appreciated!

    Tom
     
  2. Thurenity

    Thurenity Listening to some tunes

    I don't have a Dragonfly, but my two DAC's don't require any drivers for Ubuntu. Suggest the following: At the command line, type "sudo dmesg" after attaching the device to be sure it's being recognized (the last few lines should show a USB device attaching, with possibly a recognizable name as well). Then, I'd use an app like Audacity as a test to see if you can play back files through the Dragonfly.
     
  3. McLover

    McLover Forum Resident

    Location:
    East TN
    Likely not a Linux friendly device as of yet. Likely due to Linux audio peculiarities.
     
  4. riff2112

    riff2112 Well-Known Member Thread Starter

    Location:
    Arizona
    Yes, it shows up in "sudo dmesg" as Audioquest Dragonfly and also shows up in "sudo lsusb -v". So it sees the device, but I can't get any sound. I'm sure I just don't have something set correctly but I'm not that sure what that is.

    Thx!
     
  5. Bronth

    Bronth Active Member

    Location:
    Riga, Latvia
    Have you tried to right-click the volume tray icon, choose Sound Preferences and play with the Hardware and Output tabs?
     
    Rolltide likes this.
  6. slc

    slc New Member

    I run Ubuntu 14.04 LTS with Dragonfly 1.2 and the solution for me was to go to Settings > Sound. Once there make sure the Digital Output device (it should say dragonfly but it doesn't) is highlighted (it should already be). Then at the top there is a box that says "Allow louder than 100% (May distort Sound)". Click on this box so it is checked. Then slide the slider a little past 100%, even more won't distort the sound. Should all be good. I also have the bottom box "show sound volume in the menu bar" checked so I can adjust the volume there. Dragonfly recommends to set your player (web player Itunes etc.) to 25% of Max, then use the OS volume and your amp to adjust output. make sure you only have one audio line in the system, and make sure it is in the DAC. Good luck.
     
  7. John Doew

    John Doew New Member

    Thanks to "slc" post above, im now running the audioquest dragonfly 1.0 (from ebay) on an old hp elitebook 2530p laptop with Ubuntu 14.04.2 LTS. However, on my config, it does not say "audioquest...". When I plugged in the audioquest, two options showed up in Sound Settings: "Digital Output (S/PDIF)1.1 root hub" and "Analog Output 1.1 root hub". I chose the latter. I clicked on the sound icon on the top right next to system time and clicked "Sound Settings". Make sure the "Allow louder than 100%" box is checked and the slider is set past 100% just like the post above suggested. Download and install the spotify-client and you're good to go.
     
    nick99nack, cement_head and Rolltide like this.
  8. McLover

    McLover Forum Resident

    Location:
    East TN
    Thanks, glad to see this DAC works in Linux. As I plan on getting one soon.
     
    cement_head likes this.
Thread Status:
Not open for further replies.

Share This Page