Issues with my Technics SL-1200 MKII

Discussion in 'Audio Hardware' started by Beatmaniac, May 10, 2018.

  1. timind

    timind Bushy

    Location:
    Brownsburg, IN USA
    You can check your work with a meter before hooking it up. Check before assembly and do a quick check at the RCA terminals after all is buttoned up. If continuity is good you should pat yourself on the back.:righton:
     
  2. Beatmaniac

    Beatmaniac Forum Resident Thread Starter

    Location:
    Slidell, Louisiana
    Success! Table is working great. Thank you so much for your help everyone!
     
  3. Wally Swift

    Wally Swift Forum Resident

    Location:
    Brooklyn New York
    There is a fellow on Youtube called ViperFrank with many SL1200MKII repair videos. He has one that shows how to remove, clean, re-grease and reinstall a stuck VTA ring. I'm going to do this one of these days. Mine isn't stuck but tighter than normal.
     
    Beatmaniac likes this.
  4. Beatmaniac

    Beatmaniac Forum Resident Thread Starter

    Location:
    Slidell, Louisiana
    He’s the reason (along with this amazing community) I was able to repair this. His height adjustment and tone arm replacement videos are fantastic.
     
    Wally Swift likes this.
  5. Guitarded

    Guitarded Forum Resident

    Location:
    Montana
    Awesome. I just did the same thing last weekend (w/out the burned connection). Next step is replacing the wonky Pitch Control unit...my poor MK ii was pretty trashed when I got it.
     
    Beatmaniac likes this.
  6. Beatmaniac

    Beatmaniac Forum Resident Thread Starter

    Location:
    Slidell, Louisiana
    Good luck!
     
  7. Guitarded

    Guitarded Forum Resident

    Location:
    Montana
    Thanks.

    Also toying with having the Top Deck powder coated.
     

Share This Page