New 27" 5K Retina iMac No Optical Audio Out

Discussion in 'Audio Hardware' started by rockin_since_58, Dec 4, 2019 at 7:08 PM.

  1. rockin_since_58

    rockin_since_58 Forum Resident Thread Starter

    Location:
    Simi Valley, CA
    Was trying to troubleshoot some issues with my digital streaming setup and decided to connect the audio out from my new 2019 27" 5k Retina iMac to the optical in on my Vincent amp and got nothing. Unplugged the optical cable from amp and no red light...Hmm, started researching and the new iMacs did away with optical out...WTF???
     
  2. Razakoz

    Razakoz New Member

    Location:
    Utah
    Yes, that's one reason among many why I don't buy Apple stuff. They always get rid of connectivity options because they think we don't need them anymore or something.
     
  3. SamS

    SamS Forum Legend

    Location:
    Texas
    BruceS and RolandG like this.
  4. bdfin

    bdfin Well-Known Member

    Location:
    Washington State
    Looks like you'd have to either go from the mini headphone out port to RCA patch cord or USB out to a DAC then RCA in. OR it has HDMI and thunderbolt USB3 ? Something there has to work with right cabling.
     
  5. Memphisflash

    Memphisflash Forum Resident

    Location:
    Netherlands
    Using the USB output has far more advantages over optical
     
    wgb113 and olson like this.
  6. rockin_since_58

    rockin_since_58 Forum Resident Thread Starter

    Location:
    Simi Valley, CA
  7. rockin_since_58

    rockin_since_58 Forum Resident Thread Starter

    Location:
    Simi Valley, CA
    I do use the USB out to my DAC. I was having trouble with a particular piece of software that was crashing when shuffling songs and when the bitrate was different. I wanted to go from optical out into my amps DAC to see if the problem went away.
     
  8. BruceS

    BruceS Well-Known Member

    Yeah...USB to optical is is as good as it's going to get on Mac these days. Perhaps different s/w would fix? Could at least give that a go.
     
  9. rockin_since_58

    rockin_since_58 Forum Resident Thread Starter

    Location:
    Simi Valley, CA
    I am using Sonarworks True-Fi and that is the SW with the issue. There is going to be a major update in about 8 weeks so hopefully it will correct the problem. For now I set Qobuz to 16/44 which works fine. I don't think I really hear a difference between Redbook and Hi-Res anyway.
     
  10. MilMascaras

    MilMascaras Musicologist

    Location:
    Los Angeles, CA
    If you want to re-examine your Hi-Res audio output/bitrate options:
    Applications > Utilities > Audio MIDI Setup
     
  11. rockin_since_58

    rockin_since_58 Forum Resident Thread Starter

    Location:
    Simi Valley, CA
    The apps set this automatically. I have explored it though.
     
  12. jeffsab

    jeffsab Forum Resident

    Location:
    Portland, OR
    Remember when Macs just worked?
     
  13. rockin_since_58

    rockin_since_58 Forum Resident Thread Starter

    Location:
    Simi Valley, CA
    Yep and they keep making changes and removing things that I wish were still available.
     
    robertawillisjr likes this.

Share This Page